A needs newer B, B depends on C, C depends on D and D...

Hi,

I've just consider to update nailgun package to new upstream version (from 0.9.0+trunk95 to 0.9.1), it changes its build system from ant to maven.
→ depends on maven-compiler-plugin (>= 3.0) but version 2.5.1-1 is in Debian repository, necessary to upgrade it
→ newer maven-compiler-plugin needs maven-shared-incremental, however it is still just ITPed and not in repository.
→ maven-shared-incremental needs maven-shared-components (not packaged yet)
→ maven-shared-components needs maven-scm-publish-plugin (not packaged yet)
→ (...continue?)

*sigh*, I just want to do miner update for the pacakge, though...

Popular Posts